undefined reference to `FT_Load_Sfnt_Table'

Paul Millar paul at astro.gla.ac.uk
Wed Apr 12 15:22:10 CDT 2006

On Wednesday 12 Apr 2006 10:49, Saulius Krasuckas wrote:
> WRT suite build fails for quite long time already: [1]
> So that probably was caused by the patch from Huw: [2]
> It may happen because of missing FreeType 2 stuff: [3]

Yes.  I tried to get a more recent version of FreeType, but the relevant SRPM 
I tried apparently uses a .spec format that only a newer version of rpm 
supported.  So, I tried building the new version of rpm suffered the same 

Presumably there's a path to boot-strap to the new RPMs, but I think I'd be 
better off trying to get the new machine working.

> If that's the case for us (Paul Millar), can it be worked around by adding
> another configure check, guys?  Or it isn't worth an effort?

Well, that depends when FT_Load_Sfnt_Table support was added.  We can bracket 
it between v2.1.3 (which quis. has) and v2.1.9 (which Google says has the 

Cairo seems to have suffered the same problem:

So, depending which versions of freetype2 different distros use, it might be 
worth testing for it.  See:

There's a few other reports of similar problems on Mandrake 9.1, which 
apparently uses v2.1.5.  SuSE 9.x using v2.1.7 or v2.1.9, so might get away 
with it.  YMMV.



> [1] http://www.astro.gla.ac.uk/users/paulm/WRT/wrt.php?max=5&start=869
> [2] 
> [3] http://lists.freedesktop.org/archives/fontconfig/2005-June/001377.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: not available
Url : http://www.winehq.org/pipermail/wine-devel/attachments/20060412/fe3bf7b2/attachment.pgp

More information about the wine-devel mailing list