Tomas Carnecky tom at dbservice.com
Wed Feb 15 02:23:53 CST 2006

Jesse Allen wrote:
> On 2/13/06, Tomas Carnecky <tom at dbservice.com> wrote:
>> I'm really wondering why nobody has fixed the DSOUND buffer underrun bugs..
>> I get lots of these message when I run World of Warcraft:
>> err:wave:wodPlayer_ProcessMessages pcm_pause failed: Input/output error
>> err:dsound:DSOUND_MixOne underrun on sound buffer 0x7fda2038
> The problem is known.  It has to do with wine, increasing thread
> priority, and linux kernel.  Right now, the only way is to have root
> privileges.  This is not really considered a solution for wine.

I don't think this has anything to do with the kernel or the thread 
I have installed vlc for windows, then tried to play a song. Went fine, 
then I changed to the wine git directory and started compiling wine 
(make -j5), and then it started skipping. But then I started rhythmbox 
and played a song and that worked fine. So any linux-native alsa 
application works fine even if the system is under heavy load.

maybe there is a delay between the application and wineserver, or 
someone is holding a lock and doesn't let dsound mix the buffers.

Is the ALSA driver really considered incomplete? Is the OSS driver 
better? I can't really use OSS because I also need to run TeamSpeak, and 
aoss32 doesn't work with wine.


More information about the wine-devel mailing list