wine 0.9.5 - segmentation fault with some apps

Alex Villací­s Lasso a_villacis at
Thu Jan 19 09:31:56 CST 2006

penna at wrote:

>Hi all,
>        I have already posted this message at the wine-users list (sorry 
>for the cross posting but I think this subject is related to devel people 
>instead of users).
>        I am trying to install ARS V4.5.1, from Remedy, using wine-0.9.5 
>for Mandriva (RPM built by Ivan).
>        My Mandriva is 2006.
>        If I try to run the installer (called "user.exe") wine segfaults 
>        So I run "WINEDEBUG=+all wine user.exe" just to get more 
>information. Follows the end of the output just before the segfault:
>------------------ 8< ------------------
>0009:trace:virtual:VIRTUAL_SetProt 0x7fbf5000-0x7fbf5fff c-rWx
>0009:trace:virtual:VIRTUAL_DumpView View: 0x7fb20000 - 0x7fc3ffff (system)
>0009:trace:virtual:VIRTUAL_DumpView       0x7fb20000 - 0x7fc3ffff c-rWx
>0009:trace:module:load_builtin_callback loaded user32.dll 0x7fd84868 
>0009: load_dll( handle=(nil), base=0x7fb20000, size=1179648, dbg_offset=0, 
>dbg_size=0, name=0x7fd84890, filename=L"c:\\windows\\system32\\user32.dll" 
>0009: load_dll() = 0
>0009:trace:heap:RtlAllocateHeap (0x7fd80000,0000000a,000015f0): returning 
>0009:Call ntdll.RtlAllocateHeap(7fd80000,00000000,0000001a) ret=7fce4f5f
>0009:trace:heap:RtlAllocateHeap (0x7fd80000,00000002,0000001a): returning 
>0009:Ret  ntdll.RtlAllocateHeap() retval=7fd84908 ret=7fce4f5f
>0009:trace:nls:WideCharToMultiByte cp 0 L"user.exe" -> (null)
>0009:Call ntdll.RtlAllocateHeap(7fd80000,00000000,00000011) ret=7fce4fb4
>0009:trace:heap:RtlAllocateHeap (0x7fd80000,00000002,00000011): returning 
>0009:Ret  ntdll.RtlAllocateHeap() retval=7fd84930 ret=7fce4fb4
>0009:trace:nls:WideCharToMultiByte cp 0 L"user.exe" -> "user.exe"
>0009:Call ntdll.RtlAllocateHeap(7fd80000,00000000,00000012) ret=7fce526d
>0009:trace:heap:RtlAllocateHeap (0x7fd80000,00000002,00000012): returning 
>0009:Ret  ntdll.RtlAllocateHeap() retval=7fd84a08 ret=7fce526d
>0009:Call ntdll.RtlImageNtHeader(00000000) ret=7fce61da
>0009: *killed* exit_code=0
>Segmentation Fault
>--------------------- 8< ---------------------
>        I have ARS Remedy versions V3.0, V4.5.1, V5.1 and V5.1.2. 
>        The segfault problem happens with V4.5.1 and V5.1.      Version 
>5.1.2 installs but has a different problem (it complains about permission 
>even if I am the owner of the files and directories 8-P.  I have checked 
>and the owner has all permissions). Version 3.0 is too old and also 
>complains (I do not remember right now what is the complaint).
>        Please CC me because I am only subscribed at wine-users. 
>        Any clue/sugestions? More information?
>Ulisses de Sousa Penna
>Analista Consultor - Banco do Brasil
>Fone: +55-61-3310-6320   Fax: +55-61-3310-6435
Wine 0.9.6 just came out, could you please try that instead?

Where can somebody download the application? Is there a bug report for 
this application ( Just in case, are you installing on 
a VFAT partition, or on a ext2/ext3 partition?

Have you tried running the installer under winedbg ("winedbg user.exe", 
then type "cont" at the debug prompt to pass control to the 
application)? Your stack trace is missing the callback on where inside 
wine the fault occurred.

Alex Villacís Lasso

More information about the wine-devel mailing list