acad 2004 license file bug

Jaap Stolk jwstolk at
Sun Jun 18 06:36:42 CDT 2006


I'm trying to install autoCad 2004. Without winetools I got an error
message about IE6 not being found. adding the
Software\\Microsoft\\Internet Explorer\Version=6.0.2900.2180
registry key (suggested by Dan Kegel) resulted in a similar error
further on in the installation process. I'm using a clean ".wine" with
the build in MSI.

After a lot of digging through WINEDEBUG=+all and WINEDEBUG=+msimg,+msi,+msidb
I found that the installer sets the value of ACAD_MSIE_INSTALLED based
in the version of  SHDOCVW.DLL (as suggested in ).
It is done by searching for a signature in MSI:
msi:ACTION_AppSearch Searching for Property L"ACAD_MSIE_INSTALLED",
Signature_ L"SHDOCVW.DLL"

(The +msidb is missing in the Debug Channels list at: )

Adding this dll to /windows/system32/ "solved" this problem.
Note that i have set this dll to "buildin" in winecfg, but it seems
that the native dll is still used to check the version number.

Now, my question is: how can i set the version of the buildin SHDOCVW.DLL ?
And would MSI actually return the version of the buildin dll ?

I'm now back onto the "EULA not found" error. (Bug 3226)
but this time without having the winetools installed :-)
I added /.wine/dosdevices/d: -> /mnt/cdrom1  (using winecfg)
and started "wine setup.exe" from there. still no luck.


More information about the wine-devel mailing list