Can't run DirectX games on x86_64 biarch Linux

Christoph Frick frick at
Wed Mar 8 03:36:52 CST 2006

On Wed, Mar 08, 2006 at 10:18:32AM +0100, Stefan Dösinger wrote:

> > anno 1503 never ever worked for me (there where some discussion
> > about apps like this that follow a pattern with ddraw and threads,
> > that wine might be able to handle (ever)).
> Anno 1503 is not multi threaded, I had the demo running, but it was
> VERY slow.  But there might be other glx context bugs

i guess i have tried running this game over a year now - everytime it
crashes at the exact same place (choosing a flag and then switching to
"3d-mode"). last week i tar:ed it and gave up - now you tell me it works

btw: for all the d3d8 -> wined3d gurus out there another demo, that make

the vertex-shader there goes nuts (rainbow cars) and about 2/3 of the
textures looks like only one pixel-row of the texture is scaled over the
whole polygone.

the game used to work completly before that change - except the shadows
and the overlayed textures for the instruments.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 163 bytes
Desc: not available
Url :

More information about the wine-devel mailing list