Can't run DirectX games on x86_64 biarch Linux

Christian Schneider mail at
Wed Mar 8 04:24:32 CST 2006

Am Mittwoch, den 08.03.2006, 10:20 +0100 schrieb Stefan Dösinger:
> Hi,
> > > > About half a year ago I replaced my old desktop by an AMD64 box and my
> > > > previous x86 Linux from Scratch (LFS) installation by a x86_64 multilib
> > > > LFS. And since then I'm not able to run any DirectX title anymore that
> > > > used to work before.
> > I tried, but it didn't help. I've also tried different audio outputs
> > (ALSA and OSS), but the error messages are the same.
> >
> > Anyways, thanks for your reply.
> It looks to me that something went wrong with compilation. Roderic does DX 
> development on an AMD64 machine without problems. Are you sure that Wine is 
> compiled for 32 Bit? 

The question is quite obvious, but yes, I am sure its 32-bit. First, the
output of the following command is empty, so there are no 64-bit
binaries in the wine directory:

        $ file /opt/wine/lib/{,wine/}*.so /opt/wine/bin/* | grep

Second, some programs run fine with wine, e. g. pcAnywhere. And some
games do start up and show the title menu (like StarCraft or AOE2), but
crash when selecting a game.

Third, as I said before, I've compiled wine from source on a Pentium II
Debian box which doesn't even know what x86_64 is, and copied the
installation directory /opt/wine-CVS... to my x86_64 box. But that
didn't help. I also used the setarch-utility to make the Wine configure
script see an i686-machine, and setting the -m32 flags for GCC by hand,
but the effect was the same.

> Perhaps some problem with the 32 bit libraries?

In general 32-bit apps work fine on my machine. I can run Opera,
Firefox, VMware 4.5, Quake III Arena, UT2004 and much other binary
software without any problems. Are there some libs known to cause
trouble with Wine? How can I check this?


Christian Schneider

More information about the wine-devel mailing list