preloader: Setup a fake thread-local storage block pointed to by %gs. breaks RH9

Robert Reif reif at
Sat Nov 4 08:46:46 CST 2006

This last commit: 
totally breaks wine on Red Hat 9.

Red Hat 9 has been partially broken since 2.4 kernel support has been 
dropped a while back but this patch makes it totally unusable.

It is unfortunate that 2.4 kernel support has been removed from wine 
because in "The Real World" (large enterprise and dedicated or embedded 
systems) users don't have the option of upgrading the OS to the latest 
and greatest.  Some systems will never be upgraded once deployed.  
Dropping 2.4 support is a regression.

More information about the wine-devel mailing list