building outside of source tree fails - making wrong makedep

Michael [Plouj] Ploujnikov ploujj at
Sun Oct 1 07:31:37 CDT 2006

My Wine source is in ~/apps/wine-git. I'm trying to build Wine inside

So, I do this:

$ mkdir ~/apps/build_dir
$ cd ~/apps/build_dir
$ ../wine-git/configure --x-libraries=/emul/linux/x86/usr/lib/
LDFLAGS="-L/emul/linux/x86/usr/lib -L/emul/linux/x86/lib" --verbose &>
# config.output attached
# Then I run make, and this is where it fails:
$ make
make[1]: Entering directory `/home/plouj/apps/build_dir/tools'
../tools/makedep -C../../wine-git/tools -S../../wine-git -T.. -I/usr/include/fre
etype2 bin2res.c fnt2bdf.c fnt2fon.c make_ctests.c makedep.c relpath.c sfnt2fnt.
make[1]: ../tools/makedep: Command not found
make[1]: [Makefile] Error 127 (ignored)
make[1]: `../../wine-git/tools/makedep' is up to date.
make[1]: Leaving directory `/home/plouj/apps/build_dir/tools'
make[1]: Entering directory `/home/plouj/apps/build_dir/libs'
make[2]: Entering directory `/home/plouj/apps/build_dir/libs/port'
../../tools/makedep -C../../../wine-git/libs/port -S../../../wine-git -T../..  f
fs.c fstatvfs.c futimes.c getopt.c getopt1.c getpagesize.c gettid.c interlocked.
c lstat.c memcpy_unaligned.c memmove.c mkstemps.c pread.c pwrite.c readlink.c si
gsetjmp.c spawn.c statvfs.c strcasecmp.c strerror.c strncasecmp.c usleep.c

What this looks like to me is make trying to build
../../wine-git/tools/makedep which already exists, but it's trying to
use ../tools/makedep, which doesn't exist, to actually build other

I am trying to build Wine on Gentoo AMD64. You can see that the
configure command is already convoluted to achieve that. Wine _does_
build if I run make inside the source directory. It has been working
fine since before 0.9.10. That is not what I'm doing here.
I don't know anything about how make works and especially about how
the Makefiles in Wine are setup so I would appreciate any help to
track down this problem.
It's been suggested that maybe this happens because my system is
broken, but I don't want to come to that conclusion without any
evidence. My goal is not to simply blame someone but to actually fix
what is broken.

()  ASCII Ribbon Campaign
/\  - against HTML mail & vCards
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.output
Type: application/octet-stream
Size: 39644 bytes
Desc: not available
Url :

More information about the wine-devel mailing list