AMD64 compilation successful; still not working

Alexander K. Seewald alex at
Tue Oct 3 09:55:07 CDT 2006

On Mon, Oct 02, 2006 at 03:05:25PM -0700, Scott Ritchie wrote:
> On latest Debian (or at least Ubuntu), you have to force compile without
> the stack protector on by doing -fno-stack-protector.
> See this bug:
> That said, I don't actually know if that's the issue you're running
> into.

I've verified that this does not solve the problem by recompiling
wine with gcc-4.1 -fno-stack-protector. Still having basically the
same problem.

I've traced the problem to line 429 in libs/wine/config.c, execv(
full_name, new_argv ). In this call, the program exists with return
code 2. What could conceivably make this call return 2 without any
error messages?

wine-pthread --version and wine-kthread --version works, wineserver
seems to work; ./wine-preloader gives same error code 2 (csh, $?) as wine;
debugging it does not help as it is a library. I get the following message,

warning: Lowest section in system-supplied DSO at 0xffffe000 is .hash at ffffe094

I get a lot of...
 build_new_path (path=Cannot access memory at address 0xffffd748) at glibc.c:80
.. during gdb wine. Perhaps my kernel has problems running 32bit code? The
addresses seem to indicate that 32bit code might overrun on these
memory addresses, which could explain segfault etc..

Is there a way to get better error output so I can find out what is
wrong? I'm considering putting fprintf(stderr, ..) statements into the
code which surely is a bad sign. ;-)

Dr. Alexander K. Seewald

GE Money Bank, Analytics/CRM     +43(664)1106886
         Information wants to be free;
Information also wants to be expensive (S.Brant)
--------------- ----------------

More information about the wine-devel mailing list