MSI : GetInstallDriver, Can not find InstallDriver in ROT table, Return Code = 0x800401e3

wino at wino at
Wed Sep 13 20:53:09 CDT 2006


I have a refractory (faulty ?) MSI to deal with .

I ran an msi based installer for autosketch today and it all went very  
well. Thanks for the current progress on MSI.

Greatly cheered by this news I returned to one that I have never got to  
work since trying with 0.9.8 . I always thought it was wine that was not  
up to speed but it seems there some less than sorted versions of  
installsheild which give problems on some machines.

In fact it may well be ALL Installsheild from v6 to v9. Only the lastest  
is fixed.

I get the following the log file from msi:

The InstallScript engine version currently installed on this machine is  
Event 'E2716761' is created
GetInstallDriver, Can not find InstallDriver in ROT table, Return Code =  
Extract supporting files
Failed to extract _IsUser.dll, Ignore it.
Failed to extract IGdi.dll, Ignore it.
ISMsiServerStartup Failure, Failed to RegisterMsiServer, Error = 0x8000ffff
MsiServerStartup failed. Abort installation.
Shutting down the PRC server...
RPC runtime reported exception 0x6ba

Googling parts of that soon shows a known issue , even on windows:

and specifically :

symtomatically , when it gets to the stage of copying the files to $TEMP ,  
it seems to create a few zero length files only before failing.

So the bug is in InstallSheild but it does not affect all machines. This  
version _usually_ installs correctly , what remains to be found out is why  
Wine falls into the broken category and how to work around it.

Since I see this is was one area marked in 0.9.21 changelog I thought this  
may be a good time to bring it to your attention.

best regards.

More information about the wine-devel mailing list