wined3d base GLX requirement

James Hawkins truiken at
Wed Sep 27 20:56:11 CDT 2006

On 9/27/06, Ivan Gyurdiev <ivg231 at> wrote:
> The current base GLX requirement for wined3d seems to be v1.3.
> It won't compile otherwise... I wrote a patch for pbuffers, which adds
> proper extension support for SGIX_PBUFFER and SGIX_FBCONFIG, but:
> - even with the patch there's additional offenders in directx.c that
> prevent a compile with glx < 1.3 [ more FBCONFIG dependencies ]
> - there's comments in the source saying ATI supports pbuffers, but only
> advertises GLX_VERSION_1_3, without the appropriate extensions.
> So - should GLX 1.3 be considered a base requirement for wined3d, or
> should I send patches to clean up pbuffer dependencies?

There should be no base dependency for compiling wined3d.  wined3d
should still compile no matter what version glx is, or even if it's
not installed at all.  Note that I'm saying compiling, not having

James Hawkins

More information about the wine-devel mailing list