[oleaut32/tests] Error when running tests on Wine, anyone?

Paul Vriens paul.vriens.wine at gmail.com
Mon Aug 13 03:39:54 CDT 2007

Detlef Riekenberg wrote:
> On So, 2007-08-12 at 10:50 +0200, Stefan Leichter wrote:
>>>> Can somebody confirm if all oleaut32 tests run correctly on Wine. 
>>> detlef at p4:~/wine.cvs/bin$ wine dlls/oleaut32/tests/oleaut32_test.exe.so
>>> vartest
> ...
>>> vartest.c:3129: Test failed: got VT_R8(-145) expected VT_R8(-1.4)
>>> vartest: 1031878 tests executed (0 marked as todo, 1 failure), 0
>>> skipped.
>>> Intel P4 2GHz / Ubuntu 6.06
>> Should we think about localisation? 
> That's the reason for the failure!
> LANG="en_GB.UTF-8" wine ... => 0 failures
> Also for "en_GB", "it_IT", "fr_FR", "gr_GR", ....
>> Of course we are running both debian base distributions. This might be another 
>> item to look on.
> Not needed.
> Our tests are not correct for w2k and below.
> My w2k_sp4(german) has 539 failures and includes the failure from wine:
>> vartest.c:3129: Test failed: got VT_R8(-145) expected VT_R8(-1.4)
> The WRT-Resultpage has 536 failures for w2k:
> http://test.winehq.org/data/200708071000/2000_W2KProf-Admin/oleaut32:vartest.txt
OK, we have a few results now and it we know that localization is important. 
This however doesn't fix it for me, so there are more variables.

I'm running on FC7 x86_64 with gcc 4.1.2. If people can post there versions 
etc.. we can maybe come up with the other variables (this also means people 
where the tests succeeds).

So far:

- localization influences the tests (which make sense because of the '.' in 1.45 
which is a ',' in other locales)
- I have 2 failures reported (with the same results) on a FC6/FC7 x86_64. So 
maybe the 64-bit is a variable as well.



More information about the wine-devel mailing list