WINSPOOL_EnumPrinters Found 0 printers on system with 1 parallel CUPS printer

Tony Lambregts tony.lambregts at
Sun Jan 21 00:02:11 CST 2007

Michael [Plouj] Ploujnikov wrote:
> Hi,
> I'm sending this message to both wine-users and wine-devel in hopes of
> getting help from someone with knowledge of Wine's internals.
> I've had this problem for a while, but only recently have I realized
> that I better fix it soon!
> I compile my own Wine out of git. Currently, I'm running
> wine-0.9.29-g5441536 but this issue appeared long before that.
> Moreover, I stopped being able to print between Wine updates, so I
> don't think it is anything to do with changes in Wine's code.
> The simplest way to reproduce my problem is try printing in notepad.
> First, I open notepad:
> $ WINEDEBUG=+winspool wine notepad
> trace:winspool:WINSPOOL_EnumPrinters Found 0 printers
> trace:winspool:WINSPOOL_EnumPrinters Found 0 printers
> Next, I type some text. Then I go to "File -> Printer Setup". Wine
> outputs this to the console:
> trace:winspool:WINSPOOL_EnumPrinters Found 0 printers
> fixme:winspool:WINSPOOL_EnumPrinters We don't handle
> and I see a message box saying:
> "Before you can perform printer-related tasks such as page setup or
> printing a document, you need to install a printer. Please install one
> and retry."
> I've tried deleting and re-creating my ~/.wine multiple times.
> I know that wine is compiled with CUPS support
> $ ~/apps/wine-git/configure --x-libraries=/emul/linux/x86/usr/lib/
> LDFLAGS="-L/emul/linux/x86/usr/lib -L/emul/linux/x86/lib"
> --without-libcapi20 --without-libhal --without-libicu
> --without-libldap --without-libsane > /tmp/wine-config
> $ grep -i cups /tmp/wine-config
> checking cups/cups.h usability... yes
> checking cups/cups.h presence... yes
> checking for cups/cups.h... yes
> checking for -lcups soname...
> I have a local CUPS printer installed on my system:
> $ lpstat -t
> scheduler is running
> system default destination: HPDeskjet710c
> device for HPDeskjet710c: parallel:/dev/lp0
> HPDeskjet710c accepting requests since Thu Jan 18 20:26:33 2007
> printer HPDeskjet710c is idle.  enabled since Thu Jan 18 20:26:33 2007
> and I am able to print to it from other Linux applications.
> I considered tracing the winespool code ot see where it fails to find
> my printer, but it looks way too cryptic for my uninitiated eyes.
> Any help would be appreciated.
You know.. you are not the only one with this problem. I don't print all that
often and for the life of me I cannot remember the last time I tried. but I know
that it has worked for me in the past. I am using Suse 10.2 and I am not sure
that it has ever worked with this distro. I was using Fedora Core for quite a
while and I know it worked using that.

There is a bug that seems related to this.


Tony Lambregts

More information about the wine-devel mailing list