Should Wine move to LGPL 3?

Tomas Kuliavas tokul at
Fri Jul 13 11:45:58 CDT 2007

>> Code licensed under BSD is not compatible with GPLv2. They can't include
>> GPLv2 code in codebase licensed under BSD. So there is no difference
>> between GPLv2 and GPLv3 for BSD people.
> BSDv2 is compatible with all versions of the GPL. Very little code is
> left floating around under the orginal BSD license these days.

Last time I've checked programmers could use code licensed under BSD
license in GPL software, but they couldn't use code licensed under GPL in
BSD licensed software. BSD is compatible with GPL, but GPL is not
compatible with BSD.

BSD people are not concerned about compatibility of BSD license with GPL,
they are concerned about incompatibility of GPL with BSD. Same thing
applies to GPLv2 and GPLv3.

The only people worried about GPLv3 and not worried about GPLv2, are the
ones that use GPL software and restrict end user rights with hardware or


More information about the wine-devel mailing list