Slackware 11: After Wine update applications crash if WINEDEBUG not set

Victor ErV2005 at
Sat Jun 23 00:06:27 CDT 2007

I didn't get an answer for this in wine-user, so I've decided to ask this 
question here.

After upgrading wine (from 0.9.37 to 0.9.38 or from 0.9.38 to 0.9.39 - I'm not 
sure) many graphical applications started crashing if WINEDEBUG+=all or 
WINEDEBUG+=relay not set. Among those applications are Postal 1, Kiosaky's 
Cashflow 101, .kkreiger and probably more. I'm not sure if this is a bug in 
Wine or a problem in my system, because uninstalling and downgrading (even to 
0.9.34) didn't help - problem now exists in other versions as well. 
Applications crash in a "windows way" - with access violation at address 
0x7XXXXXXX. Here is a beginning of output produced by trying to 
start .kkreiger (avaliable at
Unhandled page fault on read access to 0xffffffff at address 0x7d66c9ce 
(thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0xffffffff in 32-bit 
code ?0x7d66c9ce).
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
 EIP:7d66c9ce ESP:0033e8a8 EBP:00009f80 EFLAGS:00210246(   - 00      -RIZP1)
 EAX:0033e8c8 EBX:7d68a000 ECX:00000000 EDX:00000000
 ESI:01000000 EDI:00001f80
Stack dump:
0x0033e8a8:  0033e8c8 00000000 00000000 b7fd6ff8
0x0033e8b8:  7d72aaa9 7d72aaa9 0033ec18 00001f80
0x0033e8c8:  00000000 00000000 00000000 00000000
0x0033e8d8:  00000000 00000000 00000000 00000000
0x0033e8e8:  00000000 00000000 00000000 00000000
0x0033e8f8:  00000000 00000000 00000000 00000000
=>1 0x7d66c9ce (0x00009f80)
  2 0x00000000 (0x00000000)

But it works fine if started as
WINEDEBUG=+relay wine wine pno001.exe &>/dev/null
This application worked fine before and didn't need those flags.

Kyosaky's Cashflow 101 crashes with a windows message box which 
says "Unhandled exceptionL c0000005 At address: 7ce2f9ce".
but works fine if started with WINEDEBUG=+relay

same thing with Postal 1.

There are also problems with an Alien vs Predator 2 game and some other apps 
that enumerate D3D display modes:
if program has a listbox where videomodes can be selected, this box will 
contain no strings (alien vs. predator, ragnarok online, some other apps), if 
WINEDEBUG+=all is not set. Can these problems be connected with those 

System configuration:
Slackware 11 linux with kernel on AMD Sempron 2800+ processor with 
GeForce 7100GS and 512Mb ram.

Any pointers how can I figure out what's wrong?

With best regards, Victor Eremin.

More information about the wine-devel mailing list