I need help, please

David Outteridge dajo at frii.com
Wed Sep 26 17:25:05 CDT 2007

Hello All,

I am new to Wine.  I need to use corelDRAW for non-central reasons that I will
explain if asked.  I prefer to host on *nix (currently Mandriva 2007.0), but I
can host on MS XP as a backup.  I bought the latest and greatest corelDRAW X3
(version 13) and now have spent about a week learning Wine and trying to get
corelDRAW working.  There are some problems with installation, not completely
solved yet; but I am hopeful that execution will be successful since earlier
versions are reported in the Wine application database as running well.

I have reached a point where I am beginning to understand what is going on
with the hosting, and, also, I am getting a glimmer of *how* Wine works.  But,
as everyone knows, Wine needs a lot of study to get any siginificant grasp of
*what* is happening, and I am very aware of how little I know.  I need help
and guidance to go further, otherwise I shall have to revert to MS XP.  I
should like very much to use Wine, but I am concerned that to get it going,
without help, I shall have to resort to hacks that will be of no use to anyone
in the long term, or become engulfed in a never-ending sea of detail.  So,
here I describe what has happened, and I invite anyone to point me in the
right direction, etc., for further work.

I am a programmer of many years, but I have not used C for a long time, my
preference is for another language.  I have no knowledge of Windows internals,
and not much about using it except at a fairly remote C++ application
programming level when I used Visual Dev Studio (name?) in the past.  I have
downloaded the Wine source, and have learnt how to manipulate trace messages
to see what is happening.

The first problem, with corelDRAW out of the box, with Wine 0.9.45 from rpm,
or with my downloaded/compiled code, is summarized like this:

fixme:msi:ACTION_PerformAction unhandled msi action L"InstallIEFullUI"
err:msi:ITERATE_Actions Execution halted, action L"_InstallIE" returned 1602

Notice that there is a leading "_" on one of these actions, and that part of
the other is FullUI, which seems to relate very well with one of the MS User
Interface Levels.  Can anyone tell me the significance of the leading "_", in
particular, where does it come from?  Also any help on how InstallIEFullUI is
split up (my assumption) into _InstallIE and FullUI would be helpful.

After much stirring around, hacking at everything in sight, what I have done
to deal with this error is cut-and-paste ACTION_InstallInitialize code in
msi/actions.c, and modify it suitably, to satisfy InstallIEFullUI and
_InstallIE.  And this gets me past the err:msg above; which may or may not
enable me, ultimately, to install corelDRAW.  This do-nothing-really is
something of a cop-out, of course.  I would make the effort to do something
useful, rather than simply returning a deceptive value, but there are two
reasons for not doing so.  One is that I do not know enough about Wine
code/structure/policy, etc., and I could see simply producing garbage, albeit
working, code through ignorance.  The second reason is that, I read on the
Wine website, one should not try to install IE.  What is more, Wine (from the
rpm) puts a copy of iexplore.exe in my .wine directory anyway.  So the
question here is: what should I do wrt IE and InstallIEFullUI to follow Wine

The second problem seems to me to be rather far-reaching; I think I have run
into the problem in three different ways, the last occurrence turns out to be
the next fatal step for corelDRAW installation.

The first run-in: I have run the distribution iexplore, also I have installed
three other IEs, using ies4linux.  All of these behave in the same way: they
come up properly, and the right-click/wineicon menu that closes the
application, moves it to different desktops, etc., also works, so exiting the
application is done properly, too.  My guess is that this is all done by the
window manager, however.  The problem is that IE displays no toolbar, so it is
quite useless as a browser; it is, indeed, a software boat-anchor.

The second run-in: When I ran winecfg, irfanview, regedit, etc.. under the rpm
distribution they worked well enough, although the font used was, well,
horrible, and almost unreadable.  When I moved to the source version of Wine,
the apps worked somewhat like iexplore above, except that the menus were
available, but contained MangleFont - totally unreadable, with lots of Xs in
the text.  I posted to comp.emulators.ms-windows.wine and some kind sole
suggested loading the MS core fonts, which I had never heard of; but, bingo!,
not only did this - utterly magically - solve the problem, but the font(s)
used is nice and readable.

The third run-in: The corelDRAW installation popups (dialogs?) do not display
well, in particular they appear not to refresh when appropriate.  The fatal
part comes with the license agreement box, where, in addition to most of the
popup content not displaying (mouse intervention brings up *some* things), the
"Next" button used to continue the installation does not show, nor is it
present in the popup.  Curiously, the "Cancel" button, right next to it, does
show - after its, blank, location is clicked on.  I know where the Next button
is because I cheated and ran the corelDRAW CD on the XP box, where it works,
of course.  Not being able to transmit Next to the popup is a stalemate

But here is some trace output from the same time, you will need to imagine the
trace positions in the code.  Necessarily, as above, I clicked the "Cancel"
button toward the end of this trace fragment.

trace:dajo:ITERATE_Actions POS 61 L"LicenseAgreement"
trace:dajo:ACTION_PerformUIAction      POS 21 0 0
trace:dajo:ACTION_HandleStandardAction POS 31 0 1
trace:dajo:ACTION_HandleStandardAction UNHANDLED STD ACTION L"LicenseAgreement"
trace:dajo:ACTION_PerformUIAction      POS 22  0
trace:dajo:ACTION_HandleCustomAction   UNHANDLED CTM ACTION L"LicenseAgreement"
trace:dajo:ACTION_PerformUIAction      POS 23  0
trace:dajo:ACTION_DialogBox            POS 81 L"LicenseAgreement"
trace:dajo:event_do_dialog             POS 91 L"LicenseAgreement"
trace:dajo:event_do_dialog             POS 92 L"LicenseAgreement"
trace:dajo:WineEngCreateFontInstance   POS 51 L"System"
trace:dajo:WineEngCreateFontInstance   POS 52 L"System"
trace:dajo:WineEngCreateFontInstance   POS 51 L"Tahoma"
trace:dajo:WineEngCreateFontInstance   POS 52 L"Tahoma"
trace:dajo:WineEngCreateFontInstance   POS 51 L"ArialMT"
fixme:font:WineEngCreateFontInstance Untranslated charset 77
trace:dajo:WineEngCreateFontInstance   POS 53 L"ArialMT"
trace:dajo:WineEngCreateFontInstance   POS 52 L"ArialMT"
trace:dajo:WineEngCreateFontInstance   POS 51 L"Tahoma"
trace:dajo:WineEngCreateFontInstance   POS 52 L"Tahoma"
trace:dajo:event_do_dialog             POS 91 L"CancelSetup"
trace:dajo:event_do_dialog             POS 92 L"CancelSetup"
trace:dajo:ACTION_DialogBox            POS 82 L"LicenseAgreement"
trace:dajo:ACTION_PerformUIAction      POS 24  1
trace:dajo:ACTION_PerformUIAction      HANDLED MSI ACTION L"LicenseAgreement"
trace:dajo:ACTION_PerformUIAction      POS 25  1
err:msi:ITERATE_Actions Execution halted, action L"LicenseAgreement" returned 1602

So, it appears that the untranslated character set 77 (ArialMT) is preventing
the corelDRAW popup from displaying properly - that, of course, is a wild
guess at the moment.  But, in a curious way, it ties in with the other
problems with fonts that I have experienced.

OK, so I should fix the FIXME.  But now I am back to the code/structure/policy
problem.  Is the solution as simple as hacking up ArialMT to work, or does
this need some proper action to solve a more general problem?  So this marks
the point where I decided to write what you are reading.  I need guidance on
policy mainly, I think.  I should like help on how this error, and its
solution, fits in to the larger Wine picture.

I hope that I have presented, what is becoming, my dilemma.  I *really* want
to handled these problems, and, now that I started to find my way around in
Wine, maybe do some other things, all with one objective of helping the Wine
project.  But I have other pressures on me, and I have this uncomfortable
feeling of opening ever-widening boxes of worms.  I cannot continue to spend
days of time without some feeling that the scope of the task is going to
contract rather than expand further.

In conclusion, I can report that corelDRAW X3 does not install (also see the
appDB for confirmation), which is regressive wrt version 11, which is rated as
Gold.  Some of the reasons are given above.  The required OS is either XP or
2000, an attempt to use soemthing else brings up a message stating that.

Thanks for reading this.

More information about the wine-devel mailing list