msdmo: Array parameter is passed to function as pointer so loses size information

Andrew Talbot Andrew.Talbot at
Wed Apr 9 14:18:19 CDT 2008

John Klehm wrote:

If count needs to be the size of the buffer shouldn't it
> be:
> count = NAME_SIZE * sizeof(WCHAR);
> but probably better would be DMO_MAX_NAME_SIZE and be in a header
> somewhere (dmo.h?)?
> Regards,
> John

Ah yes, whoops. I'm pretty sure I had just that lined up, but I reckon I
must have done an 'undo' or something and taken off the multiplier. I'm
hesitant to create a header just for one constant, so I shall send a patch
to bring in the multiplier and with the more descriptive name, since
Alexandre rightly dropped my descriptive comment.

Thanks for catching that!


More information about the wine-devel mailing list