Adding Mac joystick support -- build problem

Nathaniel Gray n8gray at
Sat Dec 20 19:29:47 CST 2008

Hi wine-devels,

I've got a simple goal.  I want to play IL-2 Sturmovik on my Mac
without rebooting.  This flight sim is gold-rated in the app-db, so
this should be a walk in the park, but of course the game does require
a joystick.  After a bit of poking I realized that there's no support
for joysticks under Mac OS.  I'm willing to write the code for
joystick support, and I've even gotten as far as writing a test app
under OS X that enumerates all joysticks and polls their state.  I've
looked at the linux joystick code in wine and think I can write the
equivalent code for OS X.

What I *can't* seem to do is build a wine that can run IL-2.  I've had
no problem installing and playing the demo using the 1.1.9 build at and using crossover games, but when
I build wine myself the IL-2 demo installer fails to run.  I've tried
building the 1.1.9 and 1.1.10 tarballs and using macports to install
1.1.10, all with the same result:

--- begin log output ---
Could not load Mozilla. HTML rendering will be disabled.
err:wgl:has_opengl  glx_version is 1.2 and GLX_SGIX_fbconfig extension
is unsupported. Expect problems.
wine: configuration in '/Users/n8gray/.wine' has been updated.
err:ntdll:RtlpWaitForCriticalSection section 0x7bc8a384 "loader.c:
loader_section" wait timed out in thread 0024, blocked by 0023,
retrying (60 sec)
wine: Unhandled page fault on read access to 0xffffffff at address
0x1017:0x00000c1d (thread 0025), starting debugger...
couldn't load main module (2)
Unhandled exception: page fault on read access to 0xffffffff in 32-bit
code (1017:00000c1d).
In 32 bit mode.
Register dump:
 CS:1017 SS:1217 DS:1217 ES:11ef FS:11ff GS:0037
 EIP:00000c1d ESP:000056ee EBP:00000000 EFLAGS:00010202(   - 00      - -RI1)
 EAX:00000001 EBX:00000080 ECX:000019b0 EDX:00000001
 ESI:00000000 EDI:00001217
Stack dump:
0x1217:0x56ee:  f160 7b88 0000 7597 120f 0000 0000 0468
0x1217:0x56fe:  1027 0000 0000 0000 0000 0000 0000 0000
0x1217:0x570e:  0000 0000 0000 0000 0000 0000 0000 0000
023f: sel=11ff base=7eed0000 limit=0000ffff 32-bit rw-
=>1 0x1017:0x00000c1d (0x1217:0x0000)
0x1017:0x00000c1d: call	0x0000fffe
Module	Address			Debug info	Name (7 modules)
PE	60180000-60184000	Deferred        advapi32
PE	60310000-60325000	Deferred        user32
PE	604b0000-604b4000	Deferred        gdi32
PE	61cc0000-61d0d000	Deferred        winmm
PE	622a0000-622a4000	Deferred        version
PE	7b810000-7b889000	Deferred        kernel32
PE	7bc10000-7bc14000	Deferred        ntdll
process  tid      prio (all id:s are in hex)
	0000001f    0
	0000001e    0
	00000018    0
	00000017    0
	0000000e    0
	0000000d    0
	00000011    0
	00000021    0
	00000020    0
	0000001d    0
	0000001c    0
00000022 (D) C:\windows\system32\winevdm.exe
	00000025    0 <==
	00000024    0
	00000023    0
=>1 0x1017:0x00000c1d (0x1217:0x0000)
err:ntdll:RtlpWaitForCriticalSection section 0x7b92c250 "syslevel.c:
Win16Mutex" wait timed out in thread 0023, blocked by 0025, retrying
(60 sec)
--- end log output ---

If I use Mike's build I only get these messages:
wine: created the configuration directory '/Users/n8gray/.wine'
 Could not load Mozilla. HTML rendering will be disabled.
wine: configuration in '/Users/n8gray/.wine' has been updated.

Clearly there's some magic build juju that I don't have, perhaps
related to opengl.  I've read the wiki, but I haven't found anything
that I haven't already tried.  Can anybody provide a hint as to how to
get this working?  BTW, I'm using the latest XQuartz 2.3.2_rc3
(xorg-server 1.4.2-apple27).


Nathan Gray

More information about the wine-devel mailing list