Wine Gecko packaging

Jacek Caban jack at
Tue Dec 30 09:43:10 CST 2008


Now that we have a new Gecko, the work isn't done yet. All packages have 
to be updated. Wine can use only the new version now, so if a package 
contains an older version, it won't work and Gecko installer will be 
used instead. The update is as simple as providing the new file instead 
of the old one, so I believe it's not too much work. Note that for older 
Wine versions, older Gecko must be used.

The problem is that we don't have a way to inform all packagers about 
updates (not all of them follow wine-devel) and it would be nice to have 
a communication channel so future releases won't have such problems. 
Austin suggested announcing on wine-announce. There are only a few 
people interested, so I could have a list of e-mail address or a Wiki 
page with e-mail addresses of interested people and send announcement 
e-mail directly. Please let me know, what works better.

I know about followed affected packages:
- Gentoo ebuild
I've CCed maintainer.
- Ubuntu package
- Mandriva
Marco was recently interested in providing a package
- winetricks
BTW, Dan, I think it's a good idea to have a Gecko option, but people 
should learn about if possible instead of 
depending on winetricks to do something that we already have implemented 
in Wine.

I don't know about other distros, so please let me know if I've missed 


More information about the wine-devel mailing list