[feature requist] Glide API support

Marcus Meissner meissner at suse.de
Tue Feb 19 04:12:54 CST 2008

On Tue, Feb 19, 2008 at 09:11:17AM +0000, Julius Schwartzenberg wrote:
> Vincent Weber <weber.vincent <at> gmail.com> writes:
> > 
> > Dear Wine devs,There are some games out there that were built with the Glide
> API. The Glide API is the graphics API of the 3dfx Voodoo cards and is basically
> a stripped down version of OpenGL. Could please consider adding support for the
> Glide API
> Wine already works fine with the Linux version of Glide. You need Voodoo
> hardware to be able to use this though.
> Someone could create a Glide>OpenGL library independantly of Wine and also call
> it libglide{23}x.so. Then all Linux Glide apps could use it and Wine would also
> use it automaticly. It may be handy to look into porting an opensource version
> of a currently existing wrapper from Windows.
> This is not really related to Wine directly. This wrapper could and should be
> created independantly of Wine.

Btw, we had such a wrapper some time ago ... Linking to the Linux glide2x and glide3x.  ;)

Ciao, Marcus

More information about the wine-devel mailing list