SetPixelFormat broken in 0.9.54

Roderick Colenbrander thunderbird2k at
Mon Feb 25 10:47:54 CST 2008

> I run a opengl script that worked in 0.9.53 but crashed in 0.9.54 (and
> 0.9.55)
> I traced it failed at this line
>    SetPixelFormat hdc;pixfmt;pfd
> with the following message in console:
> X Error of failed request:  BadAccess (attempt to access private resource
> denied)
>    Major opcode of failed request:  160 (Composite)
>    Minor opcode of failed request:  1 ()
>    Serial number of failed request:  164
>    Current serial number in output stream:  182
> Is this a known issue?
> ubuntu 7.10 amd64
> regards,

First I would update to the latest GIT version as a LOT has changed in the Wine's OpenGL implementation recently. Second what video drivers are you using? In short when programs contain a 'small' 3d view rendered using either opengl or direct3d, we render to an X window which is made offscreen using X Composite. The contents of this window is then copied to the right location.

The problem is that this method isn't supported on all video drivers yet. Basically it is the same functionality which is needed to get a glxgears window to render on a compiz cube.

Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen:

More information about the wine-devel mailing list