[3/10] [try 4] appwiz.cpl: Add column headers to listview

Juan Lang juan.lang at gmail.com
Thu Jul 17 13:05:10 CDT 2008


Hi Owen,

+   IDS_COLUMN_TITLE_1, "Name"
+   IDS_COLUMN_TITLE_2, "Publisher"
+   IDS_COLUMN_TITLE_3, "Version"
These seem like rather poor names for the string IDs.  Why not e.g.
IDS_COLUMN_NAME or simply IDS_NAME?

+/* Definition of column headers for AddListViewColumns function */
+#define NUM_COLUMNS   3
I don't think you need a separate symbolic constant for this, as..

+AppWizColumn columns[NUM_COLUMNS] = {
this can be replaced with:
+AppWizColumn columns[] = {

and this:
+    /* Add the columns */
+    for (i = 0; i < NUM_COLUMNS; i++)
can be replaced with:
+    for (i = 0; i < sizeof(columns) / sizeof(columns[0]; i++)

 #define IDS_CPL_TITLE          1
 #define IDS_CPL_DESC           2
 #define IDS_TAB1_TITLE         3
+#define IDS_COLUMN_TITLE_1     6
+#define IDS_COLUMN_TITLE_2     7
+#define IDS_COLUMN_TITLE_3     8
See above for the comment on the choice of names.  What happened to
items 4 and 5?
--Juan



More information about the wine-devel mailing list