EverQuest2.exe and context.c

Chris Ahrendt celticht32 at aol.com
Thu Jul 24 15:17:24 CDT 2008

Vitaliy Margolen wrote:
> Chris Ahrendt wrote:
>> Vitaliy Margolen wrote:
>>> Chris Ahrendt wrote:
>>>> Vitaliy Margolen wrote:
>>>>> Chris Ahrendt wrote:
>>>>>> Ok I ran make test and got the failure without running 
>>>>>> Everquest2.exe let me attach the output of maketest. I guess thats 
>>>>>> a start eh?
>>>>> You getting off-topic too far here. Make test have nothing to do 
>>>>> with your game. Especially that you attached complete output of 
>>>>> everything.
>>>>> However this lines tell the whole story:
>>>>>> libGL error: drmMap of framebuffer failed (Cannot allocate memory)
>>>>>> libGL error: reverting to (slow) indirect rendering
>>>>> You have broken driver. And I'm afraid your configuration can not 
>>>>> be supported. You could try and read the faq about how to try and 
>>>>> fix it. But that still won't fix broken driver.
>>>>> Vitaliy
>>>>> PS:
>>>>> Please do not attach big files to mailing list. If you are asked 
>>>>> for them - send to that person directly or attach to the bug report.
>>>>> PPS:
>>>>> Please take this discussion to the bug report. It's not a general 
>>>>> case but a game specific. It belongs there not in the developer's 
>>>>> mailing list. Since you are not a developer yourself and just add 
>>>>> an extra noise to the mailing list.
>>>> Actually Vialiy it is a discussion that belongs here... not in bug 
>>>> fix..
>>>> I have had that gl error and its not what we are working on... the 
>>>> problem we are working on was first found in EverQuest2.exe but I 
>>>> was able to reproduce it without everquest. so its not a game 
>>>> related issue.
>>>> Second point.. I was told to bring this sort of discussion over here to
>>>> discuss as the patch list is not for general discussion.
>>> I'm talking about bugzilla. What's the bug number you are referring too?
>>> Vitaliy.
>> There are a couple 14072 is one of them...
> Did you noticed that your patch has nothing to do with what you talking 
> about here? The bug related to this topic is 14000. And please don't mix 
> and match multiple things.
> Reading this thread you talking about:
> 1. Changing gotos with something
> 2. Not liking the code
> 3. PixelFormat.
> 4. make test failures (not even related to d3d at all)
> 5. dxdiag crash
> This is all on top of broken configuration (did you disable fast tls?) 
> and known bad drivers and particular bad video card.
> Please stay on topic of pixelformat related problem or you won't get 
> anywhere trying to fix everything at the same time.
> For the main topic - you will need to wait for Roderic to chime in on 
> the reasons behind his code. This area is really fragile and should not 
> be changed to fix a particular program.
> Vitaliy.
Yes I disabled fast tls... configuration is not broken...
the thread was different for each of the topics... I never said I didnt 
like the code.. if you read where I commented back to stefan I said how 
about this version of his fix instead. Then I asked in another thread 
about the goto's and fixing those.. Where I found a goto that did just a 
return and nothing else... The other point was a goto changing that to a 
  subroutine and then was explained to me that certain points gotos had 
to be used. Show me where I said I didnt like the code... I said I 
disliked goto's which is true.. I am allowed a personal opinion and 
respect others opinions.  I asked stefan where to go next when we were 
working on his fix thats when I was trying to find something which I 
could run which he could run as well without having everquest. I did 
some research  and found make test so I ran that. When I ran that I 
recieved the same problem I was experiencing with everquest. So I let 
him know that the error could be reproduced using something other than 
that.  Never had a dxdiag crash so you must be mistaking me for someone 
else.  Secondly unlike your tone I have not gotten snitty about 
things... and I don't appreciate that.  Did you ever think to look and 
see how you come across? I try to considering this is an international 
list. I realise that the ATI drivers are flaky at best.. But my card is 
not bad.. I also have no choice as to what video card that is in my 
laptop.. this is not a desktop.  I personally am, and others as well are 
tired of the you have crap get the hell out of here excuse.  I am trying 
to work at fixing the problem not complaining about the problem but FIX 
I am not trying to fix everything at the same time as I said.. the above 
is the timeline of what occured which is all related to the pixel format 

Can we all just quit with the your card is crap stuff and your driver is 
crap.. yes WE HAVE BEEN MADE AWARE OF THE FACT.  I just want to fix the 
problem. Wine should not be getting an unhandled exception when it tries 
to initialise.. at worst it should throw an error. If it can not find a 
pixelshader... where is it... Once we look at and figure out why wine is 
dying (is it a bad return code ... is the driver stomping on shared 
memory? etc...) then I can go to ATI and tell them where the problem is.

You don't know me from adam but I do deserve a little common courtesy...
I would appreciate that as I give you the same.


More information about the wine-devel mailing list