Compile wine on Red Hat 9

Michael Stefaniuc mstefani at
Fri Jun 6 11:52:45 CDT 2008

Wen Huang wrote:
> Thanks a lot Michael.
> I tried and it worked! Just curious that whether this is going to  
> affect many programs run through wine. I use wine to run WinBUGS, it  
> worked fine.
It will affect all those programs that use the Windows XML DLLs.
You could try to upgrade the libxml2 rpms on your Red Hat Linux 9 box by 
recompiling the libxml2 srpm from F9. No clue if that will work.


> On Jun 6, 2008, at 3:42 AM, Michael Stefaniuc wrote:
>> Hello!
>> Wen Huang wrote:
>>> I was trying to compile a winehq on Red Hat 9 and I downloaded the   
>>> source 0.9.60 from sourceforge.
>> Do you really mean Red Hat Linux 9? Or Fedora 9? Red Hat Linux 9 is  
>> really old and unsupported for years now.
>>> When I tried to compile by
>>> ./configure
>>> make depend
>>> make
>>> during the make step, it gave an error
>>> .....
>>> gcc -c -I. -I. -I../../include -I../../include -I/usr/include/  
>>> libxml2   -I/usr/include/libxml2   -D__WINESRC__ -DCOM_NO_WINDOWS_H  
>>> - D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration- 
>>> after- statement -Wwrite-strings -Wpointer-arith  -g -O2  -o  
>>> cdata.o cdata.c
>>> cdata.c: In function `domcdata_appendData':
>>> cdata.c:601: void value not ignored as it ought to be
>>> make[2]: *** [cdata.o] Error 1
>>> make[2]: Leaving directory `/home/tus/wine-0.9.60/dlls/msxml3'
>>> make[1]: *** [msxml3] Error 2
>>> make[1]: Leaving directory `/home/tus/wine-0.9.60/dlls'
>>> make: *** [dlls] Error 2
>>> Can anybody kindly offer some help?
>> It really depends if you use Red Hat Linux 9 or Fedora 9. For RHL9  
>> you can try to pass --without-xml to configure and see if that makes  
>> it work. But that will make the XML DLLs unusable.
>>> By the way, is there rpm package for wine I can use on Red Hat 9,  
>>> I  tried to use the script on Wine Red Hat wiki to generate a rpm,  
>>> but it  failed at the same step...

More information about the wine-devel mailing list