gdi32: Don't add duplicate system_links entries

Dmitry Timoshkov dmitry at codeweavers.com
Tue Apr 14 23:59:50 CDT 2009


"Paul TBBle Hampson" <Paul.Hampson at Pobox.com> wrote:

> +            /* Make sure we haven't already got an entry for this due to substitution */
> +            duplicate = FALSE;
> +            LIST_FOR_EACH_ENTRY(system_font_link, &system_links, SYSTEM_LINKS, entry)
> +            {
> +                if(!strcmpW(system_font_link->font_name, font_link->font_name))
> +                {
> +                    duplicate = TRUE;
> +                    break;
> +                }
> +            }

Font name comparison should be case insensitive. If there are other places
that do that they should be fixed.

> +            if(duplicate)
> +            {
> +                TRACE("\tDuplicate font_link entry, ignoring\n");
> +                HeapFree(GetProcessHeap(), 0, font_link);
> +                continue;
> +            }

A '\t' at the start of a trace message doesn't improve readability.

-- 
Dmitry.



More information about the wine-devel mailing list