Ubuntu no longer works correctly without pulseaudio

Susan Cragin susancragin at earthlink.net
Mon Apr 27 13:43:26 CDT 2009

> Bug 1813 is a really old bug for something else (fixed in 2003). Did you
>> forget a digit?
That would be http://bugs.winehq.org/show_bug.cgi?id=18133.
>- Reece

Hi. Yes, that's the bug. 
Here's everything I know, and probably more than you want to know, but I don't know what to leave out. 
My system is on the bleeding edge of everything, which can be a problem when it comes time to diagnose. 
I have been using Ubuntu Jaunty Studio since its first beta, and it's now fairly mature. I compile every wine git and test it, using Dragon NaturallySpeaking. Usually everything works as well or better than it has. 
In addition to that, I compile my own alsa-driver because I use a Creative SoundBlaster X-fi soundcard. They are a one-time install and I used the stable daily build. They had been working well for weeks, and I had not updated them in at least a day or two.  
About 10 days ago, when I did my daily wine build and installed DNS, the training froze. My first thought was a wine regression, but I was busy and didn't test for a few days. Then I did a couple of regression tests that seemed to succeed, but really the just marked the first change I tagged as the problem. I tested back further than the problem appeared. Still no luck. 
Solution? That it's not wine's problem, it is something else that has been introduced. 
Then I tried using a new alsa-driver, and a new alsa-libs with it. Nothing. 
Then I tested various configurations of pulseaudio, purged and not-purged. No changes. 
Then I reinstalled the whole Ubuntu-Studio system. 
In the meantime, Ubuntu-Studio had switched to using the Real-Time kernel as a default. The kernel froze before wine had a chance to. 
Back to the drawing board. I downloaded the generic kernel. That seemed to work for USB audio only. I tried compiling alsa-drivers, and installing them, and then USB stopped receiving sound. 
Then someone on my ubuntu-studio users list compiled a generic (non-ubuntu) realtime kernel. 
I installed it in the crudest way possible, by double-clicking on the DEB. 
Success, but for the USB soundcard only. 

The alsadriver settings that freeze during training are as follows (and they are the ones that used to work):

wave-out devices: dmix:Generic (there were three of these)
wave-in devices: dsnoop:Generic (ditto)

My working mixer device was HD-Audio-Generic. 
(I had three cards, the other mixers were HDA Intel and iMic USB audio system)

Now, to get the program to work at all without freezing, I re-install the kernel. Then only the USB works properly. The settings I see are as follows. 

wave-out devices: ALC660-VD Analog
                  USB Audio

wave-in devices: (same)

So, what do you make of all this? Are dmix and dsnoop being bypassed?


More information about the wine-devel mailing list