Sound problems with latest kernel -- formerly a pulseaudio thread but not any more

Susan Cragin susancragin at
Thu Apr 30 06:02:43 CDT 2009

>>>>> I have tested the following and I believe found they were not the problem:
>>>>> (3) problem with pulseaudio
>>>>How did you determine this? I thought you said your version of Ubuntu
>>>>was crippled if pulseaudio was removed, so did you use pasuspender? If
>>>>so, did you verify there was no pulseaudio process running while you
>>>>were testing Wine?
>>> After I started my testing, I did run into problems when I tried to re-install pulseaudio and then remove it, but the PA problem was unrelated. Ubuntu said there was a PA bug, and issued a fix. After I applied the fix, no more problems working with pulseaudio removed. So the whole thing was sort of a red herring.
>>> I have re-installed my entire system since that problem went away, and immediately purged pulseaudio, and that's where I'm working from now. Still same problem.
>>OK, thanks for that clarification.
>>So you've tracked the problem down to kernel version 2.6.29? What
>>version of ALSA drivers are in your working and broken kernels?
>I've actually tracked it to before that. 
>Wine's audio last worked with one of Ubuntu's generic kernels, probably 2.6.28-10. 
>Ubuntu's current repository kernel is 2.6.28-11. That's the one I that caused the problem. 
>The experimental bug-fix kernel is 2.6.28-12. That does not solve my problem. 
>(Here's where I got the kernel: )
>When my kernel worked, my drivers were 0.1.19 -- one of Tashaki Iwai's daily stable builds from a couple of weeks ago. 
>They are 0.1.19 now, today's daily stable build, compiled against 2.6.29-1-rt8-custom, which is what I am running at the moment. 
>My 29-rt kernel is showing the same problems as the two kernels mentioned above. 
>FWIW, the person who compiled the RT kernel said that he did so without applying the Ubuntu patches. So that tells me that the change took place outside the Ubuntu patches. 

Well, this may be a pulseaudio problem after all. It may not be a wine problem. 
For the first time this morning, I tried running audacity -- the linux version. (My system has pulseaudio purged.) 
Audacity behaves the same way under Linux it does under wine, freezing when I stop and re-start the record function. 
I filed ubuntu bug 369762. 

More information about the wine-devel mailing list