[PATCH 1/3] msxml3: Return xmlnode object from create_basic_node.

Alexandre Julliard julliard at winehq.org
Thu Aug 20 09:03:53 CDT 2009


Jacek Caban <jacek at codeweavers.com> writes:

> @@ -84,6 +83,13 @@ static inline xmlnode *impl_from_IXMLDOMNode( IXMLDOMNode *iface )
>      return (xmlnode *)((char*)iface - FIELD_OFFSET(xmlnode, lpVtbl));
>  }
>  
> +static inline IXMLDOMNode *_IXMLDOMNode_(xmlnode *This)
> +{
> +    return (IXMLDOMNode*)&This->lpVtbl;
> +}

That wrapper doesn't follow any established naming convention, and
doesn't seem quite necessary. The standard way is to simply cast to the
interface type. If you really want a wrapper it should be called
something like IXMLDOMNode_from_impl.

-- 
Alexandre Julliard
julliard at winehq.org



More information about the wine-devel mailing list