Unable to cleanly install cups-devel.i686 on a Fedora 12 x86_64 machine

Alex Villací­s Lasso a_villacis at palosanto.com
Thu Dec 10 12:37:22 CST 2009

I have just updated my setup to Fedora 12 on 64 bits, and I want to 
compile Wine for this setup. I followed the instructions at: 
http://wiki.winehq.org/WineOn64bit on the section for Fedora 12. 
However, I have the following error when trying to install the packages 
as directed by the wiki:

Error en la verificación de la transacción:
   file /usr/bin/cups-config from install of 
cups-devel-1:1.4.2-7.fc12.i686 conflicts with file from package 

Resumen de errores

What I understand from this is that /usr/bin/cups-config is provided by 
both packages, and cannot be marked as shared by both packages. I want 
to have both 32 and 64-bit support for compiling programs that use CUPS. 
Does this problem have a clean workaround? Or should I complain instead 
to the Fedora packagers?

More information about the wine-devel mailing list