Edit control messages through Comctl32 v6 module

André Hentschel nerv at dawncrow.de
Mon Dec 14 10:56:46 CST 2009

Nikolay Sivov schrieb:
> On 12/14/2009 18:19, André Hentschel wrote:
>> Roderick Colenbrander schrieb:
>>> On Sun, Dec 13, 2009 at 1:46 PM, Nikolay Sivov<bunglehead at gmail.com> 
>>> wrote:
>>>> On 12/13/2009 15:15, Roderick Colenbrander wrote:
>>>>>>> The main test which AJ suggested would be to 'force' native
>>>>>>> user32 to
>>>>>>> call RegisterClassNameW. There would be a dummy dll containing a
>>>>>>> RegisterClassNameW to which lets say the Button control would be
>>>>>>> redirected using a manifest.
>>>>>> If I got it right you're talking about a dummy dll with compiled
>>>>>> in (or
>>>>>> separate doesn't matter) manifest with
>>>>>> 'windowclass' entry (and without to check it's actually used) to
>>>>>> Button,
>>>>>> after that we trigger test application reload
>>>>>> and dump this RegisterClassNameW call someway?
>>>>> Yeah that's the idea. I'm quite certain that this mechanism is used to
>>>>> register the class.
>>>> Could you suggest a best way to generate dll on runtime, maybe it's
>>>> possible
>>>> to place in into resourse?
>>>> Any examples are welcome.
>>> In this case Alexandre just wants to know how Windows is doing the
>>> stuff. I believe this test doesn't have to be added to Wine.
>> As i understood the testcase should look like:
>> A programm with manifest which depends on a dll with e.g. a button-class
>> A dll with a manifest that tells it provides a own button-class and a
>> RegisterClassNameW function that maybe only prints out "Yeah, i got
>> called!"
>> That should run on Windows and produce that message.
> Yes, that's exactly what I tried to do yesterday.
>> Alexandre told me, that he just wants to see that this test works, but
>> its not necessary to add it to wine.
>> I ran into to some issues where windows needed a signed dll to use a
>> manifest with it. I dont know how to manage that correctly, so i got
>> stuck
> What you mean saying signed dll? I've stuck too after a first try cause
> I'm not able to load application at all, a kind of loader error
> produced, which is related to dependency dll specified with manifest.
> After a failure I tried to place a dll into a shared manifest directory
> in WinSxS/Manifests (or something like that). It didn't help.
> Did you try an embedded manifest for dll or an external xml?
Looks like the Problem i ran into, too.
I think i got a error-message on the console on winxp.
after some internetsearch i read at msdn about it, and they told to use "signed"(whatever) dlls.
There are some tools in Visual Studio, i tried but they won't sign my dll...
i guess i used http://msdn.microsoft.com/en-us/library/aa375649%28VS.85%29.aspx
and i just found that: http://social.msdn.microsoft.com/Forums/de-DE/Vsexpressvcs/thread/4b2c9202-a5db-42ce-875b-a05710daf497

i have no access to a win-machine atm with the right environment, so i will concentrate on my ARM-port, but ask me if you have further questions.

Best Regards, André Hentschel

More information about the wine-devel mailing list