Weird error for the advapi32/eventlog tests on Vista+ when running winetest

Reece Dunn msclrhd at
Wed Nov 4 14:38:00 CST 2009

2009/11/4 Paul Vriens < at>:
> Hi,
> Just noticed that we have 1 test failure on Vista+ for the advapi32/eventlog
> tests. I was sure I've tested these from Win95 up to Win7.
> When I run tests I want to do this as Administrator, so on Vista+ I select
> 'Run as Administrator' to start a command prompt, or to launch winetest.
> Running the mentioned crosscompiled tests is no problem unless you do this
> from the actual home directory (or any subdirectory) of the user that logged
> in.
> Winetest runs most of it's test in the %TEMP% directory and hence we see
> this failure. But I have no clue why (yet).
> Anyone?

What are the errors you are experiencing?

Are you getting access denied errors? If so, it may be due to the
different file access permissions. What happens when you create/delete
the files produced by winetest in the %TEMP% directory in the explorer

Do you get/need a UAC prompt for it to work? Have you tried adding UAC
information to the manifest if this is the case?

Sorry I can't help out any further as I abandoned Vista a long time ago ^_^.

- Reece

More information about the wine-devel mailing list