ws2_32: socket.c: wrapped WSASendTo/WSARecvFrom with a different function name

Mike Kaplinskiy mike.kaplinskiy at gmail.com
Sat Jul 17 18:37:18 CDT 2010


On Sat, Jul 17, 2010 at 7:02 AM, Pigeon <pigeon at pigeond.net> wrote:
>
> WSASendTo/WSARecvFrom, wrapped in a different function name, so that
> internal calls from ws2_32 itself will not trigger programs like Garena,
> which catches WSASendTo/WSARecvFrom calls.
>
> Reference: Wine Bug Id #16047
>
> ---
>  dlls/ws2_32/socket.c |   73 ++++++++++++++++++++++++++++++++++++++++---------
>  1 files changed, 59 insertions(+), 14 deletions(-)
>
>
>
>
>

The helpers shouldn't need a WINAPI (those are for exported functions
only). And don't use INT in helpers (int is fine). You might also want
to give them better names. The names tend to be something like
WS2_(lower_case_with_underscore_for_space) in that file. You may want
to align the arguments as they were before, but now I'm just
nitpicking :). If this does get in, we may want to nominate it for
stable - it's a pretty simple change.

Mike.



More information about the wine-devel mailing list