software built and worked under wine but not in vista?

Hin-Tak Leung htl10 at
Tue May 18 18:30:43 CDT 2010

I have encountered a slightly strange issue with building the windows self-extracting installer release of ghostscript ( - the self-extracting installer is created with the winzip self-extractor package, which can be manually unzipped.

The curious thing is that I can build the self-extracting installer under 32-bit wine with the win 7 SDK (on 64-bit linux). but when I tried to run the self-installer under Vista, it says %1 is not a valid win32 application. Manually unpacking the selft-extracting installer and run 'setupgs.exe' (the setup program) also gives 'setupgs.ese is not a valid win32 application' message. But the main ghostcript executable seems operational. (the setup program mostly only just copy the extracted files to "Program Files" and set up a few registry entries, but ghostscript doesn't not require those to work).

So it seems that setupgs.exe is mis-compiled under wine with win7 sdk but just happened to also work under wine. Any idea how it might happen?
I have checked things like end-of-line, but it is curious why the setupgs program works under wine but not in vista, the reverse situation compared to most.


More information about the wine-devel mailing list