Wine Gecko 1.1.0 RC1

Jacek Caban jacek at
Sat Sep 4 13:15:36 CDT 2010

  On 9/4/10 8:09 PM, Octavian Voicu wrote:
> On Sat, Sep 4, 2010 at 9:00 PM, Jacek Caban <jacek at 
> <mailto:jacek at>> wrote:
>     On 9/4/10 2:28 PM, Octavian Voicu wrote:
>>     There are some recent crashes in urlmon:url (32 bit) that seem to be
>>     related to wine gecko. The crashes are pretty random (usually
>>     crashes at "asynchronous https test", but I've seen crashes with
>>     other backtraces or in other tests, and sometimes all tests run
>>     without a crash).
>>     I don't have the debug symbols for wine-gecko installed, but I
>>     attached a log+backtrace of the crash. Tell me if you need something
>>     more.
>>     They started for me just about when we switched to wine 1.1.0, but
>>     I'm not the only one who gets them. The bad thing is that it stops
>>     the tests with a message box saying TerminateProcess failed, so it's
>>     a pretty bad crash
>     This is not new crash. It's an old, rare random crash. I've tried to
>     debug it, but didn't find the bug. I will probably come back to this
>     later, when time permits.
> But is it related to a bug in wine or gecko? Running with debug version 
> of gecko shows numerous assertion failures and at the end lots of 
> unclaimed memory, but I suppose you know about these problems.

It seems to be a problem in Wine, not Gecko. I've seen memory corruptions 
in crypt32, although they were not nessessarily crypt32 bugs.

> I know it's random, but after the upgrade to wine 1.1.0 it's become must 
> less rare for me. Again, I must stress that that is just one backtrace, 
> I've seen crashes in different places, but most happen somewhere during 
> https test (again, not in the same place all the time).

Yeah, that's the nature of random bugs.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the wine-devel mailing list