64bit debugging or 32/64bit wine coexistence?

Geoff Hart ghart at siemens-emis.com
Fri Jan 14 22:42:25 CST 2011

I'm on Fedora 14, using 64bit Wine 1.3.10, to do Winelib

Seems to work fine, except, I ran into winedbg problems, like:


I saw Eric's response:


but I presume it will take sometime for that to trickle into
Fedora's repos.

So, I thought I'd try using 32bit development, in the mean time.

ghart at 32 ~ $ winegcc -m32 crash.c -o crash32
/usr/bin/ld: Relocatable linking with relocations from format 
elf64-x86-64 (/usr/lib64/wine/libwinecrt0.a(exe_entry.o)) to format 
elf32-i386 (crash32.6JRMXE.o) is not supported
winebuild: /usr/bin/ld failed with status 1
winegcc: winebuild failed

I presumed this was because I needed to use WINEARCH=win32,
so I tried:

ghart at 32 ~ $ rm -fr ~/.win32
ghart at 32 ~ $ WINEPREFIX=~/.win32 WINEARCH=win32 winecfg
wine: created the configuration directory '/vhe/emu/users/ghart/.win32'
wine: cannot find L"C:\\windows\\system32\\wineboot.exe"
err:process:start_wineboot failed to start wineboot, err 2

Ends up with an incomplete ~/.win32.  In contrast:

ghart at 32 ~ $ rm -fr ~/.win64
ghart at 32 ~ $ WINEPREFIX=~/.win64 WINEARCH= winecfg
wine: created the configuration directory '/vhe/emu/users/ghart/.win64'
Could not load wine-gecko. HTML rendering will be disabled.
fixme:system:SetProcessDPIAware stub!
fixme:iphlpapi:NotifyAddrChange (Handle 0x63be914, overlapped 
0x63be918): stub
wine: configuration in '/vhe/emu/users/ghart/.win64' has been updated.

seems to function properly.

ghart at 32 ~ $ locate wineboot

I wondered why no /usr/lib/wine/wineboot.exe.so
ghart at 32 ~ $ ls /usr/lib/wine/wine*.so
/usr/lib/wine/winebrowser.exe.so    /usr/lib/wine/winemapi.dll.so
/usr/lib/wine/winecfg.exe.so        /usr/lib/wine/winemenubuilder.exe.so
/usr/lib/wine/wineconsole.exe.so    /usr/lib/wine/winemine.exe.so
/usr/lib/wine/winecoreaudio.drv.so  /usr/lib/wine/winepath.exe.so
/usr/lib/wine/wined3d.dll.so        /usr/lib/wine/wineps16.drv16.so
/usr/lib/wine/winedbg.exe.so        /usr/lib/wine/wineps.drv.so
/usr/lib/wine/winedevice.exe.so     /usr/lib/wine/winepulse.drv.so
/usr/lib/wine/winefile.exe.so       /usr/lib/wine/winevdm.exe.so
/usr/lib/wine/winegstreamer.dll.so  /usr/lib/wine/winex11.drv.so

I then wondered if this is some Fedora packaging issue:

root at mspl001 ~ # yum install wine.i686
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package wine.i686 0:1.3.10-1.fc14 set to be installed
--> Processing Dependency: wine-wow(x86-32) = 1.3.10-1.fc14 for package: 
--> Running transaction check
---> Package wine-wow.i686 0:1.3.10-1.fc14 set to be installed
--> Processing Conflict: wine-1.3.10-1.fc14.x86_64 conflicts 
wine-wow(x86-32) = 1.3.10-1.fc14
--> Finished Dependency Resolution
Error: wine conflicts with wine-wow

To me this suggests that wine.i686 is exclusively for 32bit,
which I'm hesitant use (I'd like to have both 32 and 64 bit
compilations at least, even if debugging is limited to 32bit).

I googled around quite a bit, and saw others mention problems
similar to mine, but didn't spot any resolution.  Can anyone
suggest a solution for either the 64bit winedbg or 32bit winegcc


More information about the wine-devel mailing list