[4/4] gdi32: Move common code into helper function.
bunglehead at gmail.com
Thu Jan 27 17:22:25 CST 2011
On 1/27/2011 12:23, Kusanagi Kouichi wrote:
> On 2011-01-26 19:28:29 +0300, Nikolay Sivov wrote:
>> On 1/26/2011 19:09, Kusanagi Kouichi wrote:
>>> -static LPSTR FONT_GetCharsByRangeA(HDC hdc, UINT firstChar, UINT lastChar, PINT pByteLen)
>>> +static LPWSTR FONT_GetCharsByRangeA(HDC hdc, UINT firstChar, UINT lastChar, PINT pLen)
>> It's better to change naming too, since it's won't return char
>> string anymore.
> What name do you think is better?
> Is FONT_GetCharsByRange or FONT_GetCharsByRangeAToW OK?
I think FONT_GetCharsByRangeW would be fine. Note that I don't know this
code, and probably it should be done another way to avoid conversion in
a first place (if possible at all).
More information about the wine-devel