usability study: "30 days with Ubuntu" author had trouble with wine

Austin English austinenglish at
Fri Jun 24 20:38:35 CDT 2011

On Fri, Jun 24, 2011 at 18:58, Dan Kegel <dank at> wrote:
> First problem - ubuntu's package manager is unclear:
> "I opened up my handy-dandy Ubuntu Software Center and typed Wine in
> the search field, and...WTF? There are 14 matching items that show up.
> Many of them are variations on 'Microsoft Windows Compatibility
> Layer'. One has '(meta package)' at the end, another has '(dummy
> package)'. They each have a little sub-title like 'wine', or
> 'wine-gecko', or 'wine1.3-gecko'. Why isn't there just a single app
> clearly called 'Wine'?
> I didn't really have any clue which of these various software packages
> is the real Wine, but the one at the top--the 'meta package'--had the
> most ratings and ranked highly at 4.5 stars, so I decided to give that
> one a shot."
> Second problem - he expected to run a program called Wine, found
> wineconfig, did something with it, and then got back on track:
> "Once it completed installing, I went to the Applications lens on the
> Unity bar and typed in Wine. It claims I have three apps installed
> that fit that description: Configure Wine, Uninstall Wine Software,
> and Winetricks. I was hoping to actually run Wine, but given these
> three options it seems that Configure Wine is the logical first
> choice.
> I clicked Configure Wine and the Wine Configuration console popped up
> (go figure). At the bottom of the Applications tab, it specific which
> version of Windows to emulate...I mean be compatible with. It defaults
> to Windows XP, but I changed it to Windows 7...
> OK. Now, I am ready to run some Windows software, right?"
> Third problem: he expected Office 2010 to install and run
> Fourth problem: he couldn't even run the installer:
> " I opened up the folder from my Windows drive where I store
> downloaded software, right-clicked my Microsoft Office 2010
> installation executable and clicked 'Open With Wine Windows Program
> Loader', an error message. Something to the effect that this
> software is not marked as executable.
> Windows logoRunning Windows software in Wine proved convoluted and
> elusive.I checked with Google, and found a helpful walk-through from
> called Using Wine on Ubuntu. Apparently, the fact that
> the software is an EXE is not obvious enough, so I have to first
> right-click the file, go into the Properties, and click a checkbox
> designating the file as executable.
> Seems convoluted. The problem is, every time I click the checkbox my
> check disappears. It won't let me make my file executable. I tried
> looking for more help on Google to no avail. I tried a couple other
> executable installation files, but couldn't mark those as executable
> either. I assume it is a permissions thing--like I need to somehow
> access the file permissions with root privileges in order to be able
> to make those changes. That is just a theory, though.
> So, no Windows software running for me just yet."
> Ouch, ouch, ouch.

These all sound like packaging problems..


More information about the wine-devel mailing list