gcc 4.6 warning report

Vincent Povirk madewokherd at gmail.com
Tue Jun 28 11:42:11 CDT 2011

> ../../../../dlls/gdiplus/tests/image.c: In function ‘test_palette’:
> ../../../../dlls/gdiplus/tests/image.c:1773:104: warning: array subscript is above array bounds [-Warray-bounds]

This is because the ColorPalette structure has an array of length 1 at
the end, which is really a variable-length array. We'd need a way to
let gcc know of this fact, without breaking compatibility with Windows
headers that declare it as an array of length 1.

On Sat, Jun 18, 2011 at 9:55 AM, Jerome Leclanche <adys.wh at gmail.com> wrote:
> Had to check a few warnings earlier and there hasn't been a warning
> report in a while, thought I'd share it. It's also still impossible to
> configure with -Werror because of warnings in configure scripts.
> Wine version
>  wine-1.3.22-203-gac90c1b ac90c1bd1878599710605fa5b4e2fe8ce224b280
> Enabled packages
>  alsa freetype gstreamer jpeg ldap openal opengl openssl png x
> xinerama xinput2 xml xrandr
> Disabled packages
>  capi cms cups curses esd fontconfig gettextpo gnutls gphoto gsm hal
> jack mpg123 nas opencl oss sane tiff v4l xslt xxf86vm
>  -msse4 -O3 -Wall
> Built on
>  Linux azura 3.0-0-generic #1-Ubuntu SMP Thu Jun 9 16:32:10 UTC 2011
> x86_64 x86_64 x86_64 GNU/Linux
> J. Leclanche

More information about the wine-devel mailing list