Problems with drawing text in 1.3.29

Damian Dixon damian.dixon at
Wed Oct 5 10:53:18 CDT 2011


I was attempting to use Wine 1.3.29 (in OpenSUSE 11.4 x86) and because of
issues pulled the source from git last night and still have problems.

I am having performance issues with DrawText (5 odd seconds to draw a simple
string) and the occasional X Error and crash.

The X Error is consistent and is as follows:

fixme:advapi:SetSecurityInfo stub
X Error of failed request:  BadLength (poly request too large or internal
Xlib length error)
  Major opcode of failed request:  151 (RENDER)
  Minor opcode of failed request:  17 (RenderCreateGlyphSet)
  Serial number of failed request:  41091
  Current serial number in output stream:  41571
Process of pid=0023 has terminated

The crash less consistent but is dependent upon the amount of text I attempt
to draw.

The last version I know this worked in was 1.1.39.

I've a few things to still try out before I attempt to create an RBT.

However I would like to know if anyone else is experiencing similar problems
and f they have solved the problem.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the wine-devel mailing list