d3dx9: Implement D3DXSHEvalConeLight

Matteo Bruni matteo.mystral at gmail.com
Tue Feb 12 15:54:26 CST 2013


in addition to what I already told you in #winehackers (that is,
please rename the test struct field red_in to red_out and red_out to
red_expected, or something like that), you should take the chance to
do some more cleanup. That means e.g. use "const" instead of "CONST"
as Rico already suggested and fix the indentation of the last comment
you're adding.

There are a few other things I don't really like but it's about code
style and my personal preferences, so you are free to ignore them.

I'd write the test structure declaration as:

    float *red_out, *green_out, *blue_out;
    const float *red_expected, *green_expected, *blue_expected;
    float radius, red_offset, green_offset, blue_offset;
test[] =
    {rout, gout, bout, table, &table[72], &table[144], 0.5f, 1.01f,
1.02f, 1.03f},
(I'm sure Gmail will wrap and make this piece of code unreadable, but well...)

In general I'd also avoid using caps in variable names (e.g.
r_intensity instead of Rintensity).

More information about the wine-devel mailing list