d3dx9 [patch 1/2]: Implement D3DXSHEvalConeLight

Matteo Bruni matteo.mystral at gmail.com
Fri Mar 1 07:59:55 CST 2013


2013/3/1 Nozomi Kodama <nozomi.kodama at yahoo.com>:
> Why is this patch marked as "not applied" by the testbot?
> In my computer, with the latest git, it applies fine.
>
> Is there a problem with testbot?
>
> Nozomi
>
>

Yeah, the old testbot has some issues. FWIW the patches applied just
fine for me.

Now, I know I'm going to be a PITA, but:

+            red_expected = test[l].red_out;
...
+            hr = D3DXSHEvalConeLight(order, &dir, test[l].radius,
1.7f, 2.6f, 3.5f, red_expected, green_expected, blue_expected);
...
+                ok(relative_error(expected, red_expected[j]) < admitted_error,

isn't really better than the previous patch. What I meant is that the
variables storing the output of D3DXSHEvalConeLight should be named in
a way that shows it's the output of the function and what we want to
test, while the variables with the expected values (the values a good
implementation of the function should return and that you use to
assess whether the implementation is working correctly) should be
named accordingly too. So you went from calling everything "out" to
calling everything "expected", which doesn't help much ;)
I'd just remove the red_expected variable and use test[l].red_out
directly. Same for green and blue of course.



More information about the wine-devel mailing list