Patch to fix bug 34324

Bruno Jesus 00cpxxx at gmail.com
Mon Feb 24 09:39:37 CST 2014


On Sat, Feb 22, 2014 at 12:19 AM, Zhenbo Li <litimetal at gmail.com> wrote:
> Sorry to bother you.
> I don't know which patch is preferred, could someone give me any suggestions?
>
> Also, I'm sorry for the format problems. I'll re-check them before sending them
> to wine-patches.
>
> Any suggestions are greatly appreciated.
> Thank you.

> --
> Have a nice day!
> Zhenbo Li

In my opinion the complex patch is better.

+ if (hFind == INVALID_HANDLE_VALUE){
+      if (GetLastError() == ERROR_PATH_NOT_FOUND)
+       SetLastError(0x7c);  /* DE_INVALIDFILES */
+    return FALSE;
+    }
+    FindClose(hFind);

You are not following the {} styles in the surrounding code.
Why using a magic value (0x7c) if there is a define(DE_INVALIDFILES)?

Best wishes,
Bruno



More information about the wine-devel mailing list