advapi32/tests: Add tests for RegQueryInfoKey.

Thomas Faber thomas.faber at reactos.org
Sun Apr 26 02:12:52 CDT 2015


On 2015-04-25 21:15, Nikolay Sivov wrote:
> On 04/25/2015 08:41 PM, Thomas Faber wrote:
>> +    todo_wine ok(classbuffer[0] == 's', "classbuffer[0] = 0x%x\n", classbuffer[0]);
>> +    todo_wine ok(classbuffer[1] == 'u', "classbuffer[1] = 0x%x\n", classbuffer[1]);
>> +    todo_wine ok(classbuffer[10] == 's', "classbuffer[10] = 0x%x\n", classbuffer[10]);
>> +    todo_wine ok(classbuffer[11] == 0, "classbuffer[11] = 0x%x\n", classbuffer[11]);
>> +    ok(classbuffer[12] == 0x55, "classbuffer[12] = 0x%x\n", classbuffer[12]);
> 
> I think it would be more readable if you tested it against a string. 
> Also hardcoded offsets could be avoided in this case.

Yeah it seemed simpler to do it by hand initially but you're right.
I'll send an updated version.


>> +    ok(classbufferW[0] == 0x5555, "classbufferW[0] = 0x%x\n", classbufferW[0]);
>> +    ok(classbufferW[1] == 0x5555, "classbufferW[1] = 0x%x\n", classbufferW[1]);
>> +    ok(classbufferW[10] == 0x5555, "classbufferW[10] = 0x%x\n", classbufferW[10]);
>> +    ok(classbufferW[11] == 0x5555, "classbufferW[11] = 0x%x\n", classbufferW[11]);
>> +    ok(classbufferW[12] == 0x5555, "classbufferW[12] = 0x%x\n", classbufferW[12]);
> 
> If first element is not changed, it's really unlikely that anything else 
> did.

This was for consistency with the ansi version. But the other change
will take care of it in any case.

Thanks!
-Thomas



More information about the wine-devel mailing list