[PATCH 1/4] wine-headers: add a winapifamily header

Martell Malone martellmalone at gmail.com
Fri Feb 6 18:10:25 CST 2015


This is related to the other patch I sent in

108880    Superseded    Martell Malone     Re: Add
d3d11_CreateDeviceAndSwapChain

I never sent in a new patch for that.
So I'm not sure how it was marked as Superseded

On Sat, Feb 7, 2015 at 12:02 AM, Martell Malone <martellmalone at gmail.com>
wrote:

> First, the 1/4 patch is really something you'll have to convince
>> Alexandre of it's the right thing to do. The easiest way is probably
>> to ask him about it on IRC. The amount of advice I can give on that
>> one is limited, but it would probably help if you could show why Wine
>> needs the winapifamily mechanism. The best way to do that may very
>> well just be to show that applications need e.g. the
>> WINAPI_FAMILY_DESKTOP_APP constant to compile against the Wine
>> headers.
>>
> I will ask him on IRC.
> Yes well it would be more correct to have the header in the case where a
> program uses that ifdef
> So this would match the official instructions from MS on using different
> api's
>
>
> I could also imagine that you'll be asked to partition the
>> other Wine headers as well if we're going to have this mechanism in
>> Wine. I.e., I don't think it makes a lot of sense to only do this for
>> a couple of dxgi headers, but not for anything else. The prefix for
>> the subject should be "include:". I'd move this patch to the end of
>> the series.
>>
> Initially I would have only done the dx stuff because mingw-w64 shares
> those headers.
> Essentially they Jacek Caban pulls in the d3d11 headers and idls from wine
> in to mingw-w64 to update.
>
> I could update the mingw-w64 project with the changes but I didn't want to
> leave wine out of the loop.
> I do understand that all headers would need to be partitioned to support
> this eventually.
> I was hoping the start would be with directx
>
>
>> The comment is pretty superfluous.
>>
> I can take it out.
>
> In patch 2/4, you have unrelated style changes for e.g.
>> IDXGIDevice2::OfferResources()
>> . I happen to like the new style better,
>> but please don't do that. First add the new stuff, then send a patch
>> to make the existing stuff consistent with dxgi.idl at the end of the
>> series.
>>
> Sure I can do that
>
> Some general style stuff:
>>   - I think "{" on the same line for enum/struct/interface declarations
>> is ugly.
>>   - Use "DXGI_OUTDUPL_DESC *desc" instead of "DXGI_OUTDUPL_DESC* desc",
>> etc.
>>   - There are a couple of parameter naming issues. e.g. "pDevice",
>> "colorSpace", "pStats", "Data", etc.
>>   - I prefer the order of things to be macros/constants, enums,
>> structs, interfaces, functions instead of having those interleaved
>> through the header.
>>   - "FLOAT" -> "float", "LPCWSTR" -> "const WCHAR *"
>>   - "num_*" -> "*_count"
>>
>> The prefix for the dxgi IDL patches should be "dxgi:", for the d3d11
>> one it should be "d3d11:".
>>
>
> Seems easy enough to follow :)
>
>
>
> On Fri, Feb 6, 2015 at 1:05 PM, Henri Verbeet <hverbeet at gmail.com> wrote:
>
>> I had a look at this series, and have a couple of comments.
>>
>> First, the 1/4 patch is really something you'll have to convince
>> Alexandre of it's the right thing to do. The easiest way is probably
>> to ask him about it on IRC. The amount of advice I can give on that
>> one is limited, but it would probably help if you could show why Wine
>> needs the winapifamily mechanism. The best way to do that may very
>> well just be to show that applications need e.g. the
>> WINAPI_FAMILY_DESKTOP_APP constant to compile against the Wine
>> headers. I could also imagine that you'll be asked to partition the
>> other Wine headers as well if we're going to have this mechanism in
>> Wine. I.e., I don't think it makes a lot of sense to only do this for
>> a couple of dxgi headers, but not for anything else. The prefix for
>> the subject should be "include:". I'd move this patch to the end of
>> the series.
>>
>> > +/* wine wants all the api's by default so we set to desktop + app */
>> > +#ifndef WINAPI_FAMILY
>> > +#define WINAPI_FAMILY WINAPI_FAMILY_DESKTOP_APP
>> > +#endif
>> The comment is pretty superfluous.
>>
>> In patch 2/4, you have unrelated style changes for e.g.
>> IDXGIDevice2::OfferResources(). I happen to like the new style better,
>> but please don't do that. First add the new stuff, then send a patch
>> to make the existing stuff consistent with dxgi.idl at the end of the
>> series.
>>
>> Some general style stuff:
>>   - I think "{" on the same line for enum/struct/interface declarations
>> is ugly.
>>   - Use "DXGI_OUTDUPL_DESC *desc" instead of "DXGI_OUTDUPL_DESC* desc",
>> etc.
>>   - There are a couple of parameter naming issues. e.g. "pDevice",
>> "colorSpace", "pStats", "Data", etc.
>>   - I prefer the order of things to be macros/constants, enums,
>> structs, interfaces, functions instead of having those interleaved
>> through the header.
>>   - "FLOAT" -> "float", "LPCWSTR" -> "const WCHAR *"
>>   - "num_*" -> "*_count"
>>
>> The prefix for the dxgi IDL patches should be "dxgi:", for the d3d11
>> one it should be "d3d11:".
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.winehq.org/pipermail/wine-devel/attachments/20150207/e59af087/attachment-0001.html>


More information about the wine-devel mailing list