d3dcompiler: Share the source with d3dcompiler_46

Matteo Bruni matteo.mystral at gmail.com
Wed Jun 24 17:40:21 CDT 2015

2015-06-24 12:15 GMT+02:00 Alistair Leslie-Hughes <leslie_alistair at hotmail.com>:

> diff --git a/dlls/d3dcompiler_46/Makefile.in b/dlls/d3dcompiler_46/Makefile.in
> index 08c5145..41c98f7 100644
> --- a/dlls/d3dcompiler_46/Makefile.in
> +++ b/dlls/d3dcompiler_46/Makefile.in
> @@ -1,6 +1,24 @@
> MODULE    = d3dcompiler_46.dll
> +IMPORTS   = dxguid uuid

That define isn't used yet, right? I guess you can keep it around but
maybe call it D3D_COMPILER_VERSION since there is such a define in
recent d3dcompiler.h from the SDK. Or just drop it for the time being
and reintroduce it when there will be a need to distinguish the
version we're compiling for from the shared code.

Otherwise it looks fine to me. Maybe rename d3dcompiler_43_main.c to
just main.c? That change can be a separate patch.

More information about the wine-devel mailing list