[PATCH 5/8] d3dx9: Reference effect pool implementation in d3dx9_base_effect structure.

Matteo Bruni matteo.mystral at gmail.com
Fri Apr 21 12:05:33 CDT 2017


2017-04-20 13:26 GMT+02:00 Paul Gofman <gofmanp at gmail.com>:

> +struct ID3DXEffectPoolImpl
> +{
> +    ID3DXEffectPool ID3DXEffectPool_iface;
> +    LONG ref;
> +};

Please rename it to "d3dx_effect_pool" or similar, while you're at it.
Same for the interface methods (d3dx_effect_pool_QueryInterface(),
...)
We want to get rid of the MS-like names for our implementation and
this seems like a good chance to clean this one up.

> -    TRACE("base %p, data %p, data_size %lu, effect %p\n", base, data, data_size, effect);
> +    TRACE("base %p, data %p, data_size %lu, effect %p, pool %p\n", base, data, data_size, effect, pool);

Since you're touching it, please add a period at the end of the message.



More information about the wine-devel mailing list