Font rendering issues after some update.

John Found johnfound at
Thu Oct 19 13:39:17 CDT 2017

After an update of the system, WINE stopped to render the fonts properly. Regardless of the registry or other system settings, following behaviour is observed:

1. The antialiasing is only grayscale.
2. The antialiasing is only if the font size is bigger than 14px. Smaller fonts are not
smoothed at all. 
3. The hinting seems to be switched off. At least for some fonts. The bitmap fonts or the fonts designed to not use smoothing (for example FixedSys Excelsior) look like usual.

All this seems to not depend on any settings of the system configuration or WINE registry. Thinking that the problem is simply broken WINE/fontconfig/freetype I tried all possible configuration tweaks from Internet. Without any effect. I mean, the font rendering never changes even by pixel.

I have second system, that worked fine, but after the today update (I am using it very rarely) the problem appeared as well.

In the same time, all other Linux applications work normally, I can change the rendering options from the usual GUI applets.

I can't say when exactly the problem appeared for the first time. But on this second system, the updated versions are:

wine: from 2.4-1 to 2.18-1
fontconfig: from 2.12.1-4 to 2.12.6-1
freetype: from 2.7.1-1 to 2.8.1-1

Any ideas how to fix the problem? Or at least how to continue the research.

John Found <johnfound at>

More information about the wine-devel mailing list