[PATCH 1/4] winevulkan: Define alloca and forceinline

Liam Middlebrook lmiddlebrook at nvidia.com
Thu Mar 5 15:50:40 CST 2020


It looks like Marvin's getting a bit confused by your patches, here's what it's 
trying (and failing) to apply:

It looks like your email it tried to merge your plaintext email body with the 
attachment, might be worth seeing what happens if you don't attach the .patch files 

The actual .patch file which you've attached applies correctly to my local tree.

On 3/5/20 9:03 AM, Joshua Ashton wrote:
> Sets up these definitions needed for future patches
> Signed-off-by: Joshua Ashton <joshua at froggi.es>
> ---
>   dlls/winevulkan/vulkan_private.h | 12 ++++++++++++
>   1 file changed, 12 insertions(+)
> diff --git a/dlls/winevulkan/vulkan_private.h b/dlls/winevulkan/vulkan_private.h
> index 17072d2341..88233daced 100644
> --- a/dlls/winevulkan/vulkan_private.h
> +++ b/dlls/winevulkan/vulkan_private.h
> @@ -34,6 +34,18 @@
>   #include "vulkan_thunks.h"
> +#if defined(__GNUC__) || defined(__clang__)
> +#include <alloca.h>
> +#define WINEVULKAN_FORCEINLINE __attribute__((always_inline)) inline

Rather than creating a new WINEVULKAN_FORCEINLINE definition here, I think you 
should just be able to use the existing FORCEINLINE definition which is supplied by 


Liam Middlebrook

> +#define WINEVULKAN_ALLOCA(x)   alloca(x)
> +#elif defined(_MSC_VER)
> +#include <malloc.h>
> +#define WINEVULKAN_FORCEINLINE __forceinline
> +#define WINEVULKAN_ALLOCA(x)   _alloca(x)
> +#else
> +#error Unsupported platform for forceinline/alloca
> +#endif
> +
>   /* Magic value defined by Vulkan ICD / Loader spec */

This email message is for the sole use of the intended recipient(s) and may contain
confidential information.  Any unauthorized review, use, disclosure or distribution
is prohibited.  If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.

More information about the wine-devel mailing list