[PATCH 2/2 resend] oleaut32: Fix rewriting FUNCDESC to FUNC_DISPATCH.

Puetz Kevin A PuetzKevinA at JohnDeere.com
Mon Sep 21 08:41:30 CDT 2020


> > On Monday, Sep 20, 2020 at 5:55 AM, Huw Davies wrote:
> > 
> On Fri, Sep 18, 2020 at 09:38:24PM -0500, Kevin Puetz wrote:
> 
> There are several things changing in this patch, please could you
> split them up?  In addition to making the patch easier to review and
> easier to fix regressions, splitting the patch will enable more
> meaningful commit subject lines to be written.

Can do. I was trying to avoid a patch that made changes that were not yet
tested, and all the fixes were needed to pass a round-trip comparison
of dispinterface derived-from dual interface.

Would you prefer a series of (separate) fixes, followed by the conformance test,
Or a conformance test (with todo_wine) followed by fixes gradually removing the todo_wine?
 
> > -/* ITypeInfo_GetNames
> > - *
> > - * Retrieves the variable with the specified member ID (or the name of the
> > - * property or method and its parameters) that correspond to the
> specified
> > - * function ID.
> > - */
> > -static HRESULT WINAPI ITypeInfo_fnGetNames( ITypeInfo2 *iface,
> MEMBERID memid,
> > -        BSTR  *rgBstrNames, UINT cMaxNames, UINT  *pcNames)
> > +/* internal function to make the inherited interfaces' methods appear
> > + * part of the interface, remembering if the top-level was dispinterface */
> > +static HRESULT ITypeInfoImpl_GetNames( ITypeInfo *iface,
> 
> typeinfo_getnames() might be a better name for this helper; those with ITypeInfoImpl_* were helpers
> it's less likely to be confused with ITypeInfo_fnGetNames.

Ok. This one was like the others in that it's a helper adding a 
`dispinterface` arg to pass whether the top-level request was a
dispinterface down the recursion into impltypes.

I indeed followed what seemed to be the naming convention of GetInternalFuncDesc 
That all ITypeInfoImpl_* were private helpers. But I it was unclear whether it was meant
as (GetInternal)FuncDesc or Get(InternalFuncDesc), since that returned TLBFuncDesc 
instead of FUNCDESC, so I didn't put an "Internal" in this name.

I don't see any existing use of typelib_* naming. though I can certainly do that
if it's you what you want.  Should I lowercase the other helpers too,
or just let this one use a different naming convention?

Or I suppose this could be ITypeInfoImpl_GetInternalNames,...

> Huw.



More information about the wine-devel mailing list