[PATCH 08/17] programs/winedbg: revamp dbg_lvalue structure and add helpers for init

Alexandre Julliard julliard at winehq.org
Tue Dec 7 11:11:30 CST 2021


Eric Pouech <eric.pouech at gmail.com> writes:

> @@ -117,16 +117,31 @@ struct dbg_type
>  
>  struct dbg_lvalue       /* structure to hold left-values... */
>  {
> -    int			cookie;	/* DLV_??? */
> -/* DLV_TARGET references an address in debuggee's address space, whereas DLV_HOST
> - * references the winedbg's address space
> - */
> -#	define	DLV_TARGET	0xF00D
> -#	define	DLV_HOST	0x50DA
> +    unsigned            where : 1; /* 1 for target (debuggee address space), 0 for host (debugger address space) */
>      ADDRESS64           addr;
>      struct dbg_type     type;
>  };
>  
> +static inline BOOL lvalue_in_debuggee(const struct dbg_lvalue* lv) {return lv->where == 1;}

'where' is not a good name for a boolean, as shown by the fact that you
then need to add a helper to translate it to its real meaning. I'd
suggest simply calling the flag 'in_debuggee' and remove the helper.

-- 
Alexandre Julliard
julliard at winehq.org



More information about the wine-devel mailing list